using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)";
string substitution = @"$1$2";
string input = @"/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}