use strict;
my $str = '/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2';
my $regex = qr/(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";