# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\([^()\n]*ppm\b[^()]*\)//gm;t' <<< "\"Menthol(0.3ppm)\" ===> \"Menthol\"
\"Michale(36 years old man)\" ===> \"Michale(36 years old man)\"
\"Good(5%, 5,500ppm)\" ===> \"Good\""