use strict;
my $str = '"Menthol(0.3ppm)" ===> "Menthol"
"Michale(36 years old man)" ===> "Michale(36 years old man)"
"Good(5%, 5,500ppm)" ===> "Good"';
my $regex = qr/\([^()\n]*ppm\b[^()]*\)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";