import Foundation
let pattern = #"\([^()\n]*ppm\b[^()]*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Menthol(0.3ppm)"   ===> "Menthol"
"Michale(36 years old man)"  ===> "Michale(36 years old man)"
"Good(5%, 5,500ppm)" ===> "Good"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)