re = /\([^()\n]*ppm\b[^()]*\)/m
str = '"Menthol(0.3ppm)" ===> "Menthol"
"Michale(36 years old man)" ===> "Michale(36 years old man)"
"Good(5%, 5,500ppm)" ===> "Good"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result