package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\([^()\n]*ppm\b[^()]*\)`)
var str = `"Menthol(0.3ppm)" ===> "Menthol"
"Michale(36 years old man)" ===> "Michale(36 years old man)"
"Good(5%, 5,500ppm)" ===> "Good"`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}