const regex = /\([^()\n]*ppm\b[^()]*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([^()\\n]*ppm\\b[^()]*\\)', 'gm')
const str = `"Menthol(0.3ppm)" ===> "Menthol"
"Michale(36 years old man)" ===> "Michale(36 years old man)"
"Good(5%, 5,500ppm)" ===> "Good"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);