$re = '/\([^()\n]*ppm\b[^()]*\)/m';
$str = '"Menthol(0.3ppm)" ===> "Menthol"
"Michale(36 years old man)" ===> "Michale(36 years old man)"
"Good(5%, 5,500ppm)" ===> "Good"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;