import re
regex = re.compile(r"\([^()\n]*ppm\b[^()]*\)", flags=re.MULTILINE)
test_str = ("\"Menthol(0.3ppm)\" ===> \"Menthol\"\n"
"\"Michale(36 years old man)\" ===> \"Michale(36 years old man)\"\n"
"\"Good(5%, 5,500ppm)\" ===> \"Good\"")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)