using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^()\n]*ppm\b[^()]*\)";
string substitution = @"";
string input = @"""Menthol(0.3ppm)"" ===> ""Menthol""
""Michale(36 years old man)"" ===> ""Michale(36 years old man)""
""Good(5%, 5,500ppm)"" ===> ""Good""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}