# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\s*youku\s*:\s*([^]]*)\]/<iframe src="http:\/\/player.youku.com\/embed\/$1"><\/iframe>/g;t' <<< "Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs]."