$re = '/\[\s*youku\s*:\s*([^]]*)\]/';
$str = 'Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs].';
$subst = "<iframe src=\"http://player.youku.com/embed/$1\"></iframe>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;