const regex = /\[\s*youku\s*:\s*([^]]*)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\s*youku\\s*:\\s*([^]]*)\\]', 'g')
const str = `Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs].`;
const subst = `<iframe src="http://player.youku.com/embed/$1"></iframe>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);