using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s*youku\s*:\s*([^]]*)\]";
string substitution = @"<iframe src=""http://player.youku.com/embed/$1""></iframe>";
string input = @"Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs].";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}