// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\s*youku\s*:\s*([^]]*)\]").unwrap();
let string = "Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs].";
let substitution = "<iframe src=\"http://player.youku.com/embed/$1\"></iframe>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}