use strict;
my $str = 'Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs].';
my $regex = qr/\[\s*youku\s*:\s*([^]]*)\]/p;
my $subst = '<iframe src="http://player.youku.com/embed/$1"></iframe>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";