import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\s*youku\\s*:\\s*([^]]*)\\]";
final String string = "Hello [youku: xxAAAJFSK] This is a test.\n"
+ "Hello2 This is test2 [ youku : y8d78fd].\n"
+ "Hello3 This is test3 [ youku\n\n"
+ ": 484fsfs].";
final String subst = "<iframe src=\"http://player.youku.com/embed/$1\"></iframe>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}