package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\s*youku\s*:\s*([^]]*)\]`)
var str = `Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs].`
var substitution = "<iframe src="http://player.youku.com/embed/$1"></iframe>"
fmt.Println(re.ReplaceAllString(str, substitution))
}