# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\s*youku\s*:\s*([^]]*)\]"
test_str = ("Hello [youku: xxAAAJFSK] This is a test.\n"
"Hello2 This is test2 [ youku : y8d78fd].\n"
"Hello3 This is test3 [ youku\n\n"
": 484fsfs].")
subst = "<iframe src=\"http://player.youku.com/embed/$1\"></iframe>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.