import Foundation
let pattern = #"\[\s*youku\s*:\s*([^]]*)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello [youku: xxAAAJFSK] This is a test.
Hello2 This is test2 [ youku : y8d78fd].
Hello3 This is test3 [ youku
: 484fsfs].
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<iframe src="http://player.youku.com/embed/$1"></iframe>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)