# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b(https?|ftp|file):?(www)?\\/\\/[-\w+&@#\\/%?=~_|!:,.;]*[-\w+&@#\\/%=~_|])/<a href='$1'>$1<\/a>/ig;t' <<< "www.google.fr"