package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])`)
var str = `www.google.fr`
var substitution = "<a href='$1'>$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}