import re
regex = re.compile(r"(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])", flags=re.IGNORECASE)
test_str = "www.google.fr"
subst = "<a href='$1'>$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)