use strict;
my $str = 'www.google.fr';
my $regex = qr/(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])/ip;
my $subst = '<a href=\'$1\'>$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";