$re = '/(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])/i';
$str = 'www.google.fr';
$subst = "<a href='$1'>$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;