const regex = /(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(https?|ftp|file):?(www)?\\\/\\\/[-\\w+&@#\\\/%?=~_|!:,.;]*[-\\w+&@#\\\/%=~_|])', 'ig')
const str = `www.google.fr`;
const subst = `<a href='$1'>$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);