re = /(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])/i
str = 'www.google.fr'
subst = '<a href=\'$1\'>$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result