import Foundation
let pattern = ##"(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"www.google.fr"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='$1'>$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)