# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([+-]?\b\d+\b)|\S+[ \t]*/$1/g;t' <<< "0 | success. id - 1234|
-10 | failure. id - 2345
"