// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([+-]?\b\d+\b)|\S+[ \t]*").unwrap();
let string = "0 | success. id - 1234|
-10 | failure. id - 2345
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}