using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?\b\d+\b)|\S+[ \t]*";
string substitution = @"$1";
string input = @"0 | success. id - 1234|
-10 | failure. id - 2345
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}