import Foundation
let pattern = #"([+-]?\b\d+\b)|\S+[ \t]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0 | success. id - 1234|
-10 | failure. id - 2345
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)