package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([+-]?\b\d+\b)|\S+[ \t]*`)
var str = `0 | success. id - 1234|
-10 | failure. id - 2345
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}