use strict;
my $str = '0 | success. id - 1234|
-10 | failure. id - 2345
';
my $regex = qr/([+-]?\b\d+\b)|\S+[ \t]*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";