import re
regex = re.compile(r"([+-]?\b\d+\b)|\S+[ \t]*")
test_str = ("0 | success. id - 1234|\n\n"
"-10 | failure. id - 2345\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)