# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(obligor_id): (\d+);obligor_id: \d+:/$1: $2;/gm;t' <<< "obligor_id: 505732;obligor_id: 505732:"