re = /(obligor_id): (\d+);obligor_id: \d+:/m
str = 'obligor_id: 505732;obligor_id: 505732:'
subst = '$1: $2;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result