use strict;
my $str = 'obligor_id: 505732;obligor_id: 505732:';
my $regex = qr/(obligor_id): (\d+);obligor_id: \d+:/mp;
my $subst = '$1: $2;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";