import re
regex = re.compile(r"(obligor_id): (\d+);obligor_id: \d+:", flags=re.MULTILINE)
test_str = "obligor_id: 505732;obligor_id: 505732:"
subst = "$1: $2;"
result = regex.sub(subst, test_str)
if result:
print(result)