#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(obligor_id): (\d+);obligor_id: \d+:"
Local $sString = "obligor_id: 505732;obligor_id: 505732:"
Local $sSubst = "$1: $2;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)