using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(obligor_id): (\d+);obligor_id: \d+:";
string substitution = @"$1: $2;";
string input = @"obligor_id: 505732;obligor_id: 505732:";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}