const regex = new RegExp('(obligor_id): (\\d+);obligor_id: \\d+:', 'gm')
const str = `obligor_id: 505732;obligor_id: 505732:`;
const subst = `$1: $2;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);