package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(obligor_id): (\d+);obligor_id: \d+:`)
var str = `obligor_id: 505732;obligor_id: 505732:`
var substitution = "$1: $2;"
fmt.Println(re.ReplaceAllString(str, substitution))
}