$re = '/(obligor_id): (\d+);obligor_id: \d+:/m';
$str = 'obligor_id: 505732;obligor_id: 505732:';
$subst = "$1: $2;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;