#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<!--([^<|\s|\[|>|go{2}gleo]).*?-->"
Local $sString = "something here<!---->" & @CRLF & _
"<!--[if IE 6]>" & @CRLF & _
"Special instructions for IE 6 here" & @CRLF & _
"<![endif]-->" & @CRLF & _
"something here<!-- -->" & @CRLF & _
"<!--[if lt IE 9]> <!-- -->" & @CRLF & _
"" & @CRLF & _
"Here is some code." & @CRLF & _
"" & @CRLF & _
"<![endif]-->" & @CRLF & _
"" & @CRLF & _
"<!--[if !IE]> -->" & @CRLF & _
"" & @CRLF & _
"<![endif]-->"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)