# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!--([^<|\s|\[|>|go{2}gleo]).*?-->"
test_str = ("something here<!---->\n"
"<!--[if IE 6]>\n"
"Special instructions for IE 6 here\n"
"<![endif]-->\n"
"something here<!-- -->\n"
"<!--[if lt IE 9]> <!-- -->\n\n"
"Here is some code.\n\n"
"<![endif]-->\n\n"
"<!--[if !IE]> -->\n\n"
"<![endif]-->")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.