const regex = /<!--([^<|\s|\[|>|go{2}gleo]).*?-->/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--([^<|\\s|\\[|>|go{2}gleo]).*?-->', 'gm')
const str = `something here<!---->
<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
something here<!-- -->
<!--[if lt IE 9]> <!-- -->
Here is some code.
<![endif]-->
<!--[if !IE]> -->
<![endif]-->`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);