using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--([^<|\s|\[|>|go{2}gleo]).*?-->";
string substitution = @"";
string input = @"something here<!---->
<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
something here<!-- -->
<!--[if lt IE 9]> <!-- -->
Here is some code.
<![endif]-->
<!--[if !IE]> -->
<![endif]-->";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}