re = /<!--([^<|\s|\[|>|go{2}gleo]).*?-->/m
str = 'something here<!---->
<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
something here<!-- -->
<!--[if lt IE 9]> <!-- -->
Here is some code.
<![endif]-->
<!--[if !IE]> -->
<![endif]-->'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result